Saftey - Broken Guard on Saw
Incident Report for 10BitWorks Status Page
Resolved
Repairs have been made. Thank you.
Posted Sep 28, 2021 - 17:00 CDT
Identified
We are aware the the protective saw guard is not functioning correctly. We will provide updates once it has been repaired.
Posted Sep 28, 2021 - 10:17 CDT
This incident affected: Sliding Compound Miter Saw.